[centos-users 244] x86_64版でyum updateエラー

CyksArt furusu @ k6.dion.ne.jp
2006年 5月 8日 (月) 11:02:10 JST


CyksArtと申します。

yum updateでエラーが発生して困っています。
使用しているのは、CentOS 4.3 x86_64版です。
エラー内容は以下の通りです。

[root @ xxxx ~]# yum update
Setting up Update Process
Setting up repositories
update                    100% |=========================|  951 B
00:00
base                      100% |=========================| 1.1 kB
00:00
contrib                   100% |=========================|  951 B
00:00
centosplus                100% |=========================|  951 B
00:00
addons                    100% |=========================|  951 B
00:00
extras                    100% |=========================| 1.1 kB
00:00
Reading repository metadata in from local files
Resolving Dependencies
--> Populating transaction set with selected packages. Please wait.
---> Downloading header for php-pear to pack into transaction set.
php-pear-5.0.4-5.centos4. 100% |=========================| 359 kB
00:01
http://ftp.riken.jp/Linux/centos/4/centosplus/x86_64/RPMS/php-pear-5.0.4-5.centos4.x86_64.rpm:
[Errno -1] Header is not complete.
Trying other mirror.
Error: failure: RPMS/php-pear-5.0.4-5.centos4.x86_64.rpm from
centosplus: [Errno 256] No more mirrors to try.

一見すると、php-pear-5.0.4-5.centos4.x86_64.rpmを
アップデートできないようなメッセージになっていますが、
このパッケージをftpサイトからダウンロードして
インストールすると、別のファイル名で同様なエラーで
アップデートが完了しません。

実は、本日、4.3のdvdを作成して、
linux updateany
として、アップグレードしたばかりですが、
4.2の時から症状がまるで改善されませんでした。

上記では、rikenのサイトをダウンロード先にしていますが、
kddilabsを指定しても同様なエラーでした。

CentOS-Base.repoファイル内容が必要であれば記述しますが、
長くなりますので、本メールには記載しません。

エラーの改善方法を御指南いただけると幸いです。

-- 
CyksArt



centos-users メーリングリストの案内