[centos-users 527] Re: Net::SSH::Perl のインストールについて

ml_rh_linux @ spiralsys.com ml_rh_linux @ spiralsys.com
2007年 6月 26日 (火) 14:39:40 JST


矢木 さん

有り難うございます。

言われるようにしたら、インストールができました。

また、perl-Net-SSH-Perl もできました。
有り難うございました。

ところが、スクリプトを実行したところ、
use Net::SFTP;
$array{user} = 'uid';
$array{password} = "pass";
$sftp = Net::SFTP->new('hogehoge.com', %array);

$sftp = Net::SFTP->new('hogehoge.com', %array);で、
以下のようなエラーが出てしまいました。

Math::BigInt: couldn't load specified math lib(s), fallback to 
Math::BigInt::Calc at /usr/lib/perl5/site_perl/5.8.8/Crypt/DH.pm line 6
Math::BigInt: couldn't load specified math lib(s), fallback to 
Math::BigInt::Calc at /usr/lib/perl5/site_perl/5.8.8/Crypt/DSA/KeyChain.pm line 6
Math::BigInt: couldn't load specified math lib(s), fallback to 
Math::BigInt::Calc at /usr/lib/perl5/site_perl/5.8.8/Crypt/DSA/Key.pm line 6
Math::BigInt: couldn't load specified math lib(s), fallback to 
Math::BigInt::Calc at /usr/lib/perl5/site_perl/5.8.8/Crypt/DSA/Util.pm line 6
Permission denied at /usr/lib/perl5/site_perl/5.8.8/Net/SFTP.pm line 62


念のため、Math::BigInt をアップグレードしましたが、正常に、インストールでき 
ているようです。
よろしくお願いします。

  Attention: After installing this package, you also need to update:

   Math::BigRat             to at least v0.19     (you have v0.15)
   bignum                   to at least v0.21     (you have v0.17)

Checking if your kit is complete...
Looks good
Writing Makefile for Math::BigInt
cp lib/Math/BigInt.pm blib/lib/Math/BigInt.pm
cp lib/Math/BigInt/CalcEmu.pm blib/lib/Math/BigInt/CalcEmu.pm
cp lib/Math/BigFloat.pm blib/lib/Math/BigFloat.pm
cp lib/Math/BigInt/Calc.pm blib/lib/Math/BigInt/Calc.pm
Manifying blib/man3/Math::BigInt::CalcEmu.3pm
Manifying blib/man3/Math::BigInt.3pm
Manifying blib/man3/Math::BigFloat.3pm
Manifying blib/man3/Math::BigInt::Calc.3pm





Manifying blib/man3/Math::BigInt::CalcEmu.3pm
Manifying blib/man3/Math::BigInt.3pm
Manifying blib/man3/Math::BigFloat.3pm
Manifying blib/man3/Math::BigInt::Calc.3pm
Writing /usr/lib/perl5/5.8.8/i386-linux-thread-multi/auto/Math/BigInt/.packlist
Appending installation info to 
/usr/lib/perl5/5.8.8/i386-linux-thread-multi/perllocal.pod




At 14:11 07/06/26, you wrote:
>矢木です。
>
>おそらくファイルの転送中にどこかでトラブルがあったのではないかと思います。
>まずwgetでファイルを取り込みます。dag.wieers.comでも働くはずですが
>apt.sw.beかdag.freshrpms.netのほうが確かでしょう。
>
>wget 
>http://apt.sw.be/packages/rpmforge-release/rpmforge-release-0.3.6-1.el5.rf.i386.rpm
>
>そのあとrpmを実行します。
>
>rpm -Uvh rpmforge-release-0.3.6-1.el5.rf.i386.rpm
>
>On 6/25/07, ml_rh_linux @ spiralsys.com <ml_rh_linux @ spiralsys.com> wrote:
> > 矢木 さん RES有り難うございます。
> >
> > rpmforgeのリポジトリをyumに加えるところで、以下のようなエラーになってしまいま
> > した。
> >
> > どの様にすればよいか、よろしくお願いします。
> >
> > rpm -Uhv
> > 
> http://dag.wieers.com/packages/rpmforge-release/rpmforge-release-0.3.6-1.el5.rf.i386.rpm
> > 
> http://dag.wieers.com/packages/rpmforge-release/rpmforge-release-0.3.6-1.el5.rf.i386.rpm
> > を取得中
> > エラー:
> > 
> http://dag.wieers.com/packages/rpmforge-release/rpmforge-release-0.3.6-1.el5.rf.i386.rpm
> > をスキップします - 転送に失敗 - 不明または予期せぬエラー
> > 警告: u 0x9085d18 ctrl 0x9086b80 nrefs != 0 (dag.wieers.com http)
>
> > >CentOSなどのrpmに基ずくシステムの場合、できるだけrpmを用いてインストール
> > >するのが望ましいと思います。今の場合ですと、
> > >
> > >yum provides "perl(Net::SSH::Perl)"
> > >
> > >で、perl-Net-SSH-Perl.noarch    1.30-1.el4.rf    rpmforge  とでます。
> > >
> > >そこで、
> > >
> > >yum install perl-Net-SSH-Perl
> > >
> > >とすると、
> > >
> > >Dependencies Resolved
> > >
> > 
 > >=============================================================================
> > >  Package                 Arch       Version          Repository        Size
> > 
 > >=============================================================================
> > >Installing:
> > >  perl-Net-SSH-Perl       noarch     1.30-2.el4.rf    rpmforge 
> 189 k
> > >Installing for dependencies:
> > >  perl-Class-Loader       noarch     2.03-1.2.el4.rf  rpmforge 
> 9.5 k
> > >  perl-Compress-Zlib      i386       1.42-1.el4.rf    rpmforge 
> 152 k
> > >  perl-Convert-ASCII-Armour  noarch     1.4-1.2.el4.rf   rpmforge 
> 11 k
> > >  perl-Convert-PEM        noarch     0.07-1.2.el4.rf  rpmforge 
> 19 k
> > >  perl-Crypt-CBC          noarch     2.22-1.el4.rf    rpmforge 
> 27 k
> > >  perl-Crypt-DES          i386       2.05-3.2.el4.rf  rpmforge 
> 19 k
> > >  perl-Crypt-DH           noarch     0.06-1.2.el4.rf  rpmforge 
> 11 k
> > >  perl-Crypt-DSA          noarch     0.14-1.el4.rf    rpmforge 
> 35 k
> > >  perl-Crypt-IDEA         i386       1.08-1.el4.rf    rpmforge 
> 32 k
> > >  perl-Crypt-Primes       i386       0.50-1.2.el4.rf  rpmforge 
> 34 k
> > >  perl-Crypt-RSA          noarch     1.58-1.el4.rf    rpmforge 
> 69 k
> > >  perl-Crypt-Random       noarch     1.25-1.2.el4.rf  rpmforge 
> 17 k
> > >  perl-Data-Buffer        noarch     0.04-1.2.el4.rf  rpmforge 
> 13 k
> > >  perl-Digest-MD2         i386       2.03-1.2.el4.rf  rpmforge 
> 40 k
> > >  perl-Math-GMP           i386       2.04-1.2.el4.rf  rpmforge 
> 51 k
> > >  perl-Math-Pari          i386       2.010706-1.el4.rf  rpmforge 
> 3.0 M
> > >  perl-Sort-Versions      noarch     1.5-1.2.el4.rf   rpmforge 
> 8.9 k
> > >  perl-Tie-EncryptedHash  noarch     1.21-1.2.el4.rf  rpmforge 
> 15 k
> > >
> > >Transaction Summary
> > 
 > >=============================================================================
> > >
> > >がインストールされました。 もちろん、rpmforgeのリポジトリをyumに
> > >加えておく必要があります。
> > >_______________________________________________
> >
>_______________________________________________
>centos-users mailing list
>centos-users @ oss.poyo.jp
>http://oss.poyo.jp/mailman/listinfo/centos-users




centos-users メーリングリストの案内