[centos-users 1309] Re: audacityを使用したいのでアドバイスお願いします

Kenzi NOIKE noike @ kce.biglobe.ne.jp
2010年 2月 16日 (火) 20:55:01 JST


野池です.

> dagから取得したaudacityをexport LAMG=Cした後、コマンドラインからaudacityをタイプすると
> 言語撰択のウインドウが表示されますが、撰択すると以下のエラーになります
> audacity: pcm.c:2691: snd_pcm_hw_params_get_rate_numden: Assertion `params && params->rate_den != 0' failed.
> export LAMG=Cしなくても同じですf(^^;

このエラーメッセージは,ALSA(サウンドデバイスドライバ) の
メッセージのようです.
# http://www.alsa-project.org/alsa-doc/alsa-lib/group___p_c_m___h_w___params.html#g1efcd3afc21267580a6b13b35d252285


o サウンドデバイスが使えるようになっているかどうかを確認する.
Audacity の 1.3.x 以降であれば,ALSA でなくても
JACK や OSS でもよいようです.

o libsamplerate を新しいバージョンに更新してみる.

o eSounD(ESD) が動いているときは,eSounD を止める.
Gnome や KDE をインストールしていると,
eSounD を使うように設定されていることがあります.

o aRts が動いているときは,それを止めるか,
$ artsdsp audacity
として起動する.

o ALSA の OSS エミュレーションを試してみる.
$ aoss audacity

> 以下が気になるところなんですが対処方法がわかりません(;_;)
> http://slashdot.jp/~typer/journal/244820

マルチバイト文字が wxGTK で引っかかっているのは,
今回は関係ないような気がします.


2010年2月15日23:37  <ueda.katuhiko @ wave.plala.or.jp>:
> 始めましてCentOS 4.7を使用してると思いこんでいるのですが
> 以下の環境で使用しています
> uname -a
> Linux localhost.localdomain 2.6.9-89.0.18.EL #1 Tue Dec 15 14:01:55 EST 2009 i686 i686 i386 GNU/Linux
>
> dagから取得したaudacityをexport LAMG=Cした後、コマンドラインからaudacityをタイプすると
> 言語撰択のウインドウが表示されますが、撰択すると以下のエラーになります
> audacity: pcm.c:2691: snd_pcm_hw_params_get_rate_numden: Assertion `params && params->rate_den != 0' failed.
> export LAMG=Cしなくても同じですf(^^;
> 以下が気になるところなんですが対処方法がわかりません(;_;)
> http://slashdot.jp/~typer/journal/244820
> _______________________________________________
> centos-users mailing list
> centos-users @ oss.poyo.jp
> http://oss.poyo.jp/mailman/listinfo/centos-users
> CentOS Japanese Planet:
> http://oss.poyo.jp/centos-ja/planet/

-- 
// Kenzi NOIKE


centos-users メーリングリストの案内