[centos-users 1408] rlwrap でハングアップ・エラー

katagiri e.katagiri @ teikokupr.co.jp
2010年 7月 20日 (火) 08:44:27 JST


片桐です。

RHEL-4 の開発環境として、CentOS-5.5 を使用しています。
トラブっているのは、RHELの方なのでこちらポストするのは
筋違いかも知れませんが、よろしくお願いします。

rlwrap-0.37 を使用していますが、CentOS-5.5 では問題なく動いています。

〜〜〜〜〜〜〜〜 ここから 〜〜〜〜〜〜〜〜〜〜
$ /usr/local/bin/rlwrap /ifs/bin/prdmy
品番を入力して下さい。[XXX-]XXXXXX[-X] or ? or E/e
073055

# K01-073055-0
ハングアップ
〜〜〜〜〜〜〜〜 ここまで 〜〜〜〜〜〜〜〜〜〜

prdmy はPythonプログラムです。
この「ハングアップ」の意味は何でしょうか?

rlwrap のコンパイル時にreadline のバージョンが古くてコンパイル・エラーが
発生しました。そこで、readline-6.1 をインストールしました。
rlwrap のコンパイルはOKでした。
Pythonのreadline もバージョンを一致させましたが、状況は変わりません。

CentOS-5.5 は readline-5.1 なので普通にインストールするだけで
問題ありません。RHEL-5 も問題ありません。

アドバイスをお願いします。



centos-users メーリングリストの案内