[centos-users 1666] CENTOS6.6のyum install glusterfs-server できなくて困っています(西村)

yoshihome ilovefd @ topaz.plala.or.jp
2015年 6月 8日 (月) 09:48:46 JST


西村と言います

昨年、問題なく入ったGLUSTERFSーSERVERを別のPCに再インストールしようとし 
ているのですがうまく行かずこまっています。
詳しく無いので、いい解決法があったら教えていただけないでしょうか?

下記のようなメッセージが出てglusterfs-server-3.7.1-1.el6.x86_64 でなく 
glusterfs-fuse-3.6.0.28-2.el6.x86_64 を使えと言ってきているようです。

glusterfs-server-3.7.1-1.el6.x86_64.rpm 自体は
https://download.gluster.org/pub/gluster/glusterfs/LATEST/RHEL/epel-6.5/x86_64/
にあるようなので取ってくればよいのかもしれませんが、追加アプリの管理デー 
タベースがおかしくならないか心配です。

ーーーーーーーーーーーーーーーーーーーーーーーーーーーーーーーーーーーーーーーーーーーーーーーーーーー

[root @ fs2 ~]#  yum -y install glusterfs-server
読み込んだプラグイン:fastestmirror, priorities, refresh-packagekit, security
インストール処理の設定をしています
Loading mirror speeds from cached hostfile
epel/metalink                                            | 4.0 kB     00:00
  * base: centos.mirror.secureax.com
  * epel: ftp.kddilabs.jp
  * extras: ftp.iij.ad.jp
  * rpmforge: ftp.kddilabs.jp
  * updates: centos.mirror.secureax.com
base                                                     | 3.7 kB     00:00
extras                                                   | 3.4 kB     00:00
glusterfs-epel                                           | 2.9 kB     00:00
glusterfs-noarch-epel                                    | 2.9 kB     00:00
rpmforge                                                 | 1.9 kB     00:00
updates                                                  | 3.4 kB     00:00
1684 packages excluded due to repository priority protections
依存性の解決をしています
--> トランザクションの確認を実行しています。
---> Package glusterfs-server.x86_64 0:3.7.1-1.el6 will be インストール
--> 依存性の処理をしています: glusterfs-fuse = 3.7.1-1.el6 のパッケージ: 
glusterfs-server-3.7.1-1.el6.x86_64
--> 依存性の処理をしています: glusterfs-cli = 3.7.1-1.el6 のパッケージ: 
glusterfs-server-3.7.1-1.el6.x86_64
--> 依存性の処理をしています: pyxattr のパッケージ: 
glusterfs-server-3.7.1-1.el6.x86_64
--> 依存性の処理をしています: python-argparse のパッケージ: 
glusterfs-server-3.7.1-1.el6.x86_64
--> 依存性の処理をしています: liburcu-cds.so.1()(64bit) のパッケージ: 
glusterfs-server-3.7.1-1.el6.x86_64
--> 依存性の処理をしています: liburcu-bp.so.1()(64bit) のパッケージ: 
glusterfs-server-3.7.1-1.el6.x86_64
--> トランザクションの確認を実行しています。
---> Package glusterfs-server.x86_64 0:3.7.1-1.el6 will be インストール
--> 依存性の処理をしています: glusterfs-fuse = 3.7.1-1.el6 のパッケージ: 
glusterfs-server-3.7.1-1.el6.x86_64
--> 依存性の処理をしています: glusterfs-cli = 3.7.1-1.el6 のパッケージ: 
glusterfs-server-3.7.1-1.el6.x86_64
---> Package python-argparse.noarch 0:1.2.1-2.el6.centos will be インス 
トール
---> Package pyxattr.x86_64 0:0.5.0-1.el6 will be インストール
---> Package userspace-rcu.x86_64 0:0.7.7-1.el6 will be インストール
--> 依存性解決を終了しました。
エラー: パッケージ: glusterfs-server-3.7.1-1.el6.x86_64 (glusterfs-epel)
              要求: glusterfs-cli = 3.7.1-1.el6
             利用可能: glusterfs-cli-3.6.0.28-2.el6.x86_64 (base)
                 glusterfs-cli = 3.6.0.28-2.el6
             利用可能: glusterfs-cli-3.6.0.29-2.el6.x86_64 (updates)
                 glusterfs-cli = 3.6.0.29-2.el6
エラー: パッケージ: glusterfs-server-3.7.1-1.el6.x86_64 (glusterfs-epel)
              要求: glusterfs-fuse = 3.7.1-1.el6
             利用可能: glusterfs-fuse-3.6.0.28-2.el6.x86_64 (base)
                 glusterfs-fuse = 3.6.0.28-2.el6
             利用可能: glusterfs-fuse-3.6.0.29-2.el6.x86_64 (updates)
                 glusterfs-fuse = 3.6.0.29-2.el6
  問題を回避するために --skip-broken を用いることができません
  これらを試行できます: rpm -Va --nofiles --nodigest







centos-users メーリングリストの案内