[centos-users 1721] Xorgが起動しません。

辻田 昌伸 qianta @ hotmail.co.jp
2017年 1月 22日 (日) 10:45:50 JST


centosユーザさんへ

こんにちは、辻田です。


 linuxはMulti-user対応だから、6人以上ログイン出きると思い、ログインしていくとパソコンが停止したので、電源かビデオカードを買い換えれば良いのかと思いました。それで、奮発して、分割払いで買いました。

 ですが、コンソール画面には6人までしかログイン出来ないことが分かりました。

仮想端末を開けば、もう少しログインできるのでしょう。


NVIDIAのドライバをインストールしたら、Xorgが起動しなくなりました。


lspci

  VGA compatible controller: NVIDIA Corporation GP106 [GeForce GTX 1060 6GB] (rev a1)


 kernel versionは

3.10.0-514.el7.x86_64

3.10.0.514.2.2.el7.x86_64

3.10.0.514.6.1.el7.x86_64

で/bootにある、initramfsの.imgファイルを-nouveau.imgにmvして、dracutしました。


 そして、/etc/modprobe.dにmodprobe.conf、nouveau_blacklist.confを作成しました。


 Xorgが起動しません。


Xorg.0.logを開くと、

~

xf86EnableIOPorts: failded to set IOPL for I/O (Operation not permitted)

(EE) [drm] failed to open DRM device for pci :0000:01:00.0: -19

(EE) open /dev/drv/card0: No such file or directory

(WW) Falling back to old probe method for modesetting

(EE) open /dev/drv/card0: No such file or directory

(II) Loading sub module "fbdevhw"

(II) LoadModule: "fbdevhw"

(II) Loading /usr/lib64/xorg/modules/libfbdevhw.so

(II) Module fbdevhw: vendor="X.Org Fundation"

     compiled for 1.17.2 module version = 0.0.2

     ABI class: X.Org video Driver, version 19.8

(**) FBDEV(1): claimed PCI slot 100:0:0

(II) FBDEV(1): using default device

(WW) Falling back to old probe method for vesa

(EE) Screen 0 deleted because of no matching config section.

~

(EE) AIGLX: reverting software rendering

~

(EE) FBDEV(0): FBIOBLANK: Invalid argment


ログは長いので(EE)の所を抜粋しました。


どうすればXorgが起動するのでしょうか、解決策を教えてください。

よろしくお願いします。


ーーーーーーーーーーーーーーー

辻田 昌伸

qianta @ hotmail.co.jp
-------------- next part --------------
HTMLの添付ファイルを保管しました...
URL: <http://oss.poyo.jp/pipermail/centos-users/attachments/20170122/d8520610/attachment.html>


centos-users メーリングリストの案内